Build Framework7 for web/html

Framework7 adalah front-end framework untuk HTML berbasis open-source dan gratis untuk mengembangkan aplikasi mobile hibryd (cordova) atau aplikasi berbasis web dengan tampilan dan nuansa asli iOS & Android. Ini juga bisa menjadi tool untuk aplikasi prototipe yang diperlukan untuk menunjukkan prototipe aplikasi yang berfungsi sesegera mungkin jika Anda memerlukannya. Kami lebih suka menggunakan framework7 originalnya karena bahasa yg digunakan sama persis dengan fungsi javascript/jquery pada umumnya dan bisa digunakan untuk aplikasi web yg menggunakan bahasa server PHP sekalipun, karena pada prinsipnya ini adalah front-end framework yg bisa digunakan dimanapun Framework7 juga menyediakan keperluan untuk melakukan pemrograman menggunakan vue, react, dan svelte. Kami akan berikan cara untuk mem-build framework7 core yg bisa digunakan untuk javascript standar caranya sebagai berikut (Maaf mohon disesuaikan jika anda pengguna windows)
git clone https://github.com/framework7io/framework7.git 
cd framework7 
npm install 
npm run build-core:prod
Jika akan digunakan untuk vue, react, maupun svelte, maka baris terakhir untuk build bisa menyesuaikan dengan dokumentasi dsini Pemasangan di html menggunakan kode berikut
<link href="assets/framework7/packages/core/framework7-bundle.min.css" rel="stylesheet" /> 
<script src="assets/framework7/packages/core/framework7-bundle.js"></script> 
Terimakasih

Continue Reading

FIX: We Couldn’t Create A New Partition Or Locate An Existing One

Tutorial langkah demi langkah ini guna bagaimana cara memperbaiki “We couldn’t create a new partition or locate an existing one. For more information, see the Setup log files" ketika melakukan instalasi dari Windows 10/8/7. Saat melakukan instalasi, banyak pengguna menemukan kesalahan berikut saat memilih lokasi untuk menginstal Windows:
We Couldn’t Create A New Partition Or Locate An Existing One in Windows 10
Jika Anda juga mendapatkan masalah ini saat menginstal Windows 10, tutorial ini bermanfaat untuk Anda.

Continue Reading

Merubah repository ubuntu ke Indo (All version)

Untuk menggantinya, kita backup terlebih dahulu Repository bawaan melalui terminal dengan mengetik;
cp /etc/apt/sources.list /etc/apt/sources.list.bk
Setelah backup berhasil, kemudian jalankan script berikut, nanti akan otomatis berpindah ke repo lokal sesuai code_name versi ubuntu yang sedang digunakan

Continue Reading

Cara mengatasi phpMyAdmin Forbidden Error 403 (xampp)

untuk windows
  1. buka xampp\apache\conf\extra\httpd-xampp.conf
  2. cari bagian
        Alias /phpmyadmin "C:/xampp/phpMyAdmin/" 
        <Directory "C:/xampp/phpMyAdmin"> 
            AllowOverride AuthConfig 
            Require local 
            ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var 
        </Directory> 
    
  3. ubah menjadi
        Alias /phpmyadmin "C:/xampp/phpMyAdmin/" 
        <Directory "C:/xampp/phpMyAdmin"> 
      Order allow,deny 
      Allow from all 
      Require all granted 
        </Directory>
  4. restart xampp apache
untuk linux
  1. buka /opt/lampp/etc/extra/httpd-xampp.conf
  2. cari bagian
        Alias /phpmyadmin "/opt/lampp/phpmyadmin" 
        <Directory "/opt/lampp/phpmyadmin"> 
            AllowOverride AuthConfig Limit 
            Order allow,deny 
            Allow from all 
        </Directory> 
    
  3. ubah menjadi
        Alias /phpmyadmin "/opt/lampp/phpmyadmin" 
        <Directory "/opt/lampp/phpmyadmin"> 
            AllowOverride AuthConfig Limit 
            Order allow,deny 
            Allow from all 
            Require all granted 
        </Directory>
  4. restart xampp apache

Continue Reading

Mengaktifkan L2TP IPSec di mikrotik

Salah satu service VPN yang terdapat di Mikrotik adalah L2TP (Layer 2 Tunneling Protocol). L2TP merupakan pengembangan dari PPTP ditambah L2F. Network security Protocol dan enkripsi yang digunakan untuk autentikasi sama dengan PPTP. Akan tetapi untuk melakukan komunikasi, L2TP menggunakan UDP port 1701. Biasanya untuk keamaanan yang lebih baik, L2TP dikombinasikan dengan IPSec, menjadi L2TP/IPSec. Contohnya untuk Operating system Windows, secara default OS Windows menggunakan L2TP/IPSec. Akan tetapi, konsekuensinya tentu saja konfigurasi yang harus dilakukan tidak se-simple PPTP. Dari segi enkripsi, tentu enkripsi pada L2TP/IPSec memiliki tingkat sekuritas lebih tinggi daripada PPTP yg menggunakan MPPE. Trafik yang melewati tunnel L2TP akan mengalami overhead 12%. 

Continue Reading

Moodle dengan SSL proxy server (Nginx/HAproxy)

Secara standart untuk merubah http menjadi https pada moodle bisa melakukan konfigurasi pada file config.php bagian
$CFG->wwwroot
Tetapi jika anda menggunakan proxy ataupun balancer (bisa dengan nginx ataupun HAproxy) maka ada pengaturan tambahan yg diperlukan, yakni dengan menambahkan

Continue Reading

Block Windows Update (Mikrotik)

Berikut adalah script yang bisa anda kopas ke mikrotik supaya semua windows di jaringan kamu tidak melakukan update
/ip firewall raw 
add action=drop chain=prerouting content=update.microsoft.com comment="Blocking Windows Update" 
add action=drop chain=prerouting content=download.microsoft.com 
add action=drop chain=prerouting content=download.windowsupdate.com 
add action=drop chain=prerouting content=windowsupdate.com 
add action=drop chain=prerouting content=wustat.windows.com 
add action=drop chain=prerouting content=ntservicepack.microsoft.com 
add action=drop chain=prerouting content=stats.microsoft.com 
add action=drop chain=prerouting content=wustat.windows.com 
add action=drop chain=prerouting content=windowsupdate.microsoft.com

Continue Reading

The power of documents

Kami sajikan dengan bahasa yang mudah dengan disertai command line yang bisa di copy-paste sehingga memudahkan untuk melakukan modifikasi command line