Cara mengatasi phpMyAdmin Forbidden Error 403 (xampp)

untuk windows
  1. buka xampp\apache\conf\extra\httpd-xampp.conf
  2. cari bagian
        Alias /phpmyadmin "C:/xampp/phpMyAdmin/" 
        <Directory "C:/xampp/phpMyAdmin"> 
            AllowOverride AuthConfig 
            Require local 
            ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var 
        </Directory> 
    
  3. ubah menjadi
        Alias /phpmyadmin "C:/xampp/phpMyAdmin/" 
        <Directory "C:/xampp/phpMyAdmin"> 
      Order allow,deny 
      Allow from all 
      Require all granted 
        </Directory>
  4. restart xampp apache
untuk linux
  1. buka /opt/lampp/etc/extra/httpd-xampp.conf
  2. cari bagian
        Alias /phpmyadmin "/opt/lampp/phpmyadmin" 
        <Directory "/opt/lampp/phpmyadmin"> 
            AllowOverride AuthConfig Limit 
            Order allow,deny 
            Allow from all 
        </Directory> 
    
  3. ubah menjadi
        Alias /phpmyadmin "/opt/lampp/phpmyadmin" 
        <Directory "/opt/lampp/phpmyadmin"> 
            AllowOverride AuthConfig Limit 
            Order allow,deny 
            Allow from all 
            Require all granted 
        </Directory>
  4. restart xampp apache

Continue Reading

Mengaktifkan L2TP IPSec di mikrotik

Salah satu service VPN yang terdapat di Mikrotik adalah L2TP (Layer 2 Tunneling Protocol). L2TP merupakan pengembangan dari PPTP ditambah L2F. Network security Protocol dan enkripsi yang digunakan untuk autentikasi sama dengan PPTP. Akan tetapi untuk melakukan komunikasi, L2TP menggunakan UDP port 1701. Biasanya untuk keamaanan yang lebih baik, L2TP dikombinasikan dengan IPSec, menjadi L2TP/IPSec. Contohnya untuk Operating system Windows, secara default OS Windows menggunakan L2TP/IPSec. Akan tetapi, konsekuensinya tentu saja konfigurasi yang harus dilakukan tidak se-simple PPTP. Dari segi enkripsi, tentu enkripsi pada L2TP/IPSec memiliki tingkat sekuritas lebih tinggi daripada PPTP yg menggunakan MPPE. Trafik yang melewati tunnel L2TP akan mengalami overhead 12%. 

Continue Reading

Moodle dengan SSL proxy server (Nginx/HAproxy)

Secara standart untuk merubah http menjadi https pada moodle bisa melakukan konfigurasi pada file config.php bagian
$CFG->wwwroot
Tetapi jika anda menggunakan proxy ataupun balancer (bisa dengan nginx ataupun HAproxy) maka ada pengaturan tambahan yg diperlukan, yakni dengan menambahkan

Continue Reading

Block Windows Update (Mikrotik)

Berikut adalah script yang bisa anda kopas ke mikrotik supaya semua windows di jaringan kamu tidak melakukan update
/ip firewall raw 
add action=drop chain=prerouting content=update.microsoft.com comment="Blocking Windows Update" 
add action=drop chain=prerouting content=download.microsoft.com 
add action=drop chain=prerouting content=download.windowsupdate.com 
add action=drop chain=prerouting content=windowsupdate.com 
add action=drop chain=prerouting content=wustat.windows.com 
add action=drop chain=prerouting content=ntservicepack.microsoft.com 
add action=drop chain=prerouting content=stats.microsoft.com 
add action=drop chain=prerouting content=wustat.windows.com 
add action=drop chain=prerouting content=windowsupdate.microsoft.com

Continue Reading

Mematikan Windows Update

Windows 10 dengan segudang fitur barunya memang sangat keren, tetapi di satu sisi OS ini juga mimpi buruk bagi kamu yang memiliki kuota internet pas-pasan. Hal ini karena fitur Automatic Update di Windows 10 secara default tidak bisa dimatikan, khususnya di Windows 10 Home. Cara ini tentu saja tidak kita rekomendasikan bagi kamu yang kuota internetnya unlimited, karena update dari Microsoft cukup penting (kadang perbaikan bugs, peningkatan fungsionalitas fitur, atau patch security). Tetapi bagi kamu yang kuota internetnya kembang-kempis ataupun justru jika mengalami update windows jadi blank, boleh mengikuti salah satu trik ini.

Cara 1. Mematikan Services Windows Update

Dengan cara ini Windows Update akan mati total, termasuk juga update untuk patch security. Jadi pastikan jika kamu menggunakan cara ini, begitu terhubung ke internet dengan kuota melimpah segera lakukan update agar Windows kamu tetap secure dan optimal. Untuk mematikan automatic update di Windows 10 dengan cara mematikan services nya, langsung saja buka Services. NB: Mematikan Windows Update Services bisa membuat kamu tidak bisa menggunakan Store dan tidak bisa mendownload Modern Apps. Resiko ditanggung penumpang.

Cara 2. Modifikasi Melalui Group Policy

Cukup buka Run dengan Win + R > ketikkan gpedit.msc > Enter Browse ke Computer Configuration > Administrative Templates > Windows Components > Windows Update. Lalu klik kanan Configure Automatic Update > Edit Setelah itu pilih opsi Enabled dan ubah automatic updating configuration ke Notify for download and notify for install > OK dan Apply Dengan begitu jika ada update yang dirilis, Windows 10 tidak akan langsung download, melainkan akan memberi notifikasi terlebih dahulu.  

Continue Reading

Mendapatkan Notifikasi untuk Free Memory Desktop/Server

Free Memory adalah memory RAM yang tersisa dan bisa digunakan. Sebagai SysAdmin akan membutuhkan ini untuk mengetahui free memory yang tersedia oleh server, karena untuk mengantisipasi jika terjadi low memory yang mengakibatkan lemotnya sever. Berikut saya berikan contoh script yang sudah dimanfaatkan untuk debian Desktop supaya ada notif ke layar jika memory low Silahkan modifikasi sesuai kebutuhan, anda bisa melakukan modifikasi jika menginginkan akan mengirim email jika server low memory, script berikut berbasis PHP sehingga mudah untuk dimodifikasi
#!/opt/lampp/bin/php 
<?php $alert_percent = ($argc > 1) ? (int)$argv[1] : 90; 
$interval      = ($argc > 2) : (int)$argv[2] : 25; 
//while(true) { 
        exec("free", $free); 
        $free = implode(' ',$free); 
        preg_match_all("/(?<=\s)\d+/", $free, $match); list($total_mem, $used_mem, $free_mem, $shared_mem, $buffered_mem, $cached_mem) = $match[0]; $used_mem -= ($buffered_mem + $cached_mem); $percent_used = (int)(($used_mem * 100) / $total_mem); if($percent_used > $alert_percent) 
                exec("notify-send 'Low Memory: $percent_used% used'"); 
//      sleep($interval); 
//} 
exit(); 
untuk menjalankan bisa dengan ./filescript.php PERHATIAN: Jika akan dijalankan melalui daemon silahkan hilangkan tanda comment supaya bisa script berjalan tanpa henti dan selalu cek ke memory pada interval waktu tertentu Semoga informasi ini bisa membantu

Continue Reading

Setting IP Static di ubuntu 20.04/18.04 (Netplan) (Server)

Untuk ubuntu terbaru ini terdapat perbedaan dalam melakukan konfigurasi ip static yakni sekarang menggunakan netplan. Pada ubuntu sebelumnya dalam mengkonfigurasi IP Static adalah dengan melakukan konfigurasi pada /etc/network/interface sedangkan pada ubuntu terbaru bukan lagi disitu melainkan harus melakukan konfigurasi pada netplan. Ada perbedaan silahkan ikuti petunjuk singkat berikut:

Continue Reading

The power of documents

Kami sajikan dengan bahasa yang mudah dengan disertai command line yang bisa di copy-paste sehingga memudahkan untuk melakukan modifikasi command line